更新PHP到8.0后typecho出现Array and string offset access syntax with curly braces is deprecated

修改一处代码/var/Json.php根据提示将{0} 改为[0]

折腾 2021-05-30 AM 185次 0条

CentOS7 安装 PHP8

由于CentOS7的默认PHP版本是PHP5,但是如果我们要安装新版本的PHP7或者8的话要怎么搞最方便呢?当然使用那些一键集成的脚本也是可以的,比如宝塔面板-LNMP等傻瓜式操作,也能达到效果但是感觉一下子安装的东西就多了,于是一顿操作发现了这个 Remi's RPM repository 官方地址:https://rpms.remirepo.net/ ,进一步发现 有国内的清华大学的源...

运维 2020-09-29 PM 894次 0条

Ubuntu 安装 PHP7.2、Apache2和MySQL

安装Apachesudo apt install apache2安装php7.2sudo apt-get install software-properties-common python-software-propertiessudo add-apt-repository ppa:ondrej/php && sudo apt-get updatesudo apt-get -...

运维 2018-11-16 PM 3161次 0条

隐藏Nginx或Apache以及PHP的版本号的方法

首先来看nginx中隐藏版本号的方法:在nginx配置文件nginx.conf中,加入以下代码server_tokens off;apache中隐藏版本号的方法:在apache配置文件httpd.conf中,加入以下代码ServerTokens Prod ServerSignature Off再来看php中隐藏版本号的方法:在php配置文件php.ini中,加入以下代码expose_php ...

运维,折腾 2018-04-23 PM 1726次 0条

Warning: call_user_func_array() expects parameter 1 to be a valid callback, function 'disable_autosave

在 php的配置文件php.ini中找到display_errors = Off(把on 改为Off)就可以屏蔽掉了。。。

折腾 2017-09-28 AM 3917次 1条

如何让php支持sqlite

PHP5已经绑定sqlite,只要我们开启就好了1、打开PHP.ini(去掉前面的分号注释开启) extension=php_pdo.dll extension=php_pdo_sqlite.dll extension=php_sqlite.dll2、重启apache或IIS3、OK 搞定!这么简单的东西被网上一大堆所谓的教程给弄迷糊了,害的我折腾半天!自己写个好了 CNM!

折腾 2017-03-28 PM 1974次 0条